blob: 475c830c7bf5bf181a87726fc9058a821f970def [file] [log] [blame]
Ed Tanous9eeb80f2020-08-17 15:16:39 -07001#This is largely to improve our build times by not building or installing
Andrew Geissler56a82922020-11-03 08:16:37 -06002#modules that OpenBMC does not use by our coding standard. Another thing to
3#note is that for most targets, coroutine and context libraries are also added
Patrick Williams12fc9392021-08-06 09:16:53 -05004#with a BOOST_LIBS:append:<platform> for most targets. Chrono/Thread should not
Andrew Geissler56a82922020-11-03 08:16:37 -06005#be relied directly, but are required dependencies of context and coroutine.
6#See the relevant portion of the openbmc coding standard with regards to boost
7#libraries
Ed Tanous9eeb80f2020-08-17 15:16:39 -07008#
9#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
10#
Jason M. Bills0be39b32022-08-25 11:40:15 -070011BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
12PACKAGECONFIG:openbmc-phosphor:class-target = ""
Ed Tanous9eeb80f2020-08-17 15:16:39 -070013