blob: d3ad3c0a5a8a859b2ec1e0f84a1ef1d5eb57fe90 [file] [log] [blame]
Joel Stanleye8f268e2018-04-23 10:50:44 +09301HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
2LICENSE = "GPLv2+"
3
4SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master"
5SRC_URI += "file://uart-render-controller.service"
6
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
10
11inherit autotools
12inherit pkgconfig
13inherit systemd
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
Patrick Williams12fc9392021-08-06 09:16:53 -050017RDEPENDS:${PN} += "fbterm"
Joel Stanleye8f268e2018-04-23 10:50:44 +093018
Oskar Senftb9d1f012021-11-16 08:29:43 -050019SRCREV = "08e854a6c425011d029e4e02241afee5060f15eb"
Joel Stanleye8f268e2018-04-23 10:50:44 +093020PV = "0.1+git${SRCPV}"
21
22S = "${WORKDIR}/git"
23
Patrick Williams12fc9392021-08-06 09:16:53 -050024SYSTEMD_SERVICE:${PN} += "uart-render-controller.service"
Joel Stanleye8f268e2018-04-23 10:50:44 +093025
Patrick Williams12fc9392021-08-06 09:16:53 -050026do_install:append() {
Joel Stanleye8f268e2018-04-23 10:50:44 +093027 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
29}