blob: 23623d7868eee9b9ffd2bee10ae53bb6bfd311ae [file] [log] [blame]
Jie Yang7fe1bad2021-08-06 12:41:16 -07001SUMMARY = "GLOME Login Client"
2DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9inherit meson pkgconfig
10
11DEPENDS += " \
12 openssl \
13 glib-2.0 \
14 "
15
16S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
William A. Kennington IIIe0599f22021-09-29 13:15:35 -070018SRCREV = "02f7d2722a2eb303f1f02d0c2ce97a65f8273662"
Jie Yang7fe1bad2021-08-06 12:41:16 -070019
20FILES_${PN} += "${libdir}/security"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
24PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
25
26EXTRA_OEMESON = "-Dtests=disabled"