blob: 4c0e769721ee192d810f78b0ddbaa0ebe7796252 [file] [log] [blame]
Joel Stanley7259c7d2019-11-04 23:43:51 +10301SUMMARY = "eCMD"
2DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
3LICENSE= "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
5
Patrick Williamsbb99d222022-01-24 15:55:09 -06006SRC_URI = "git://github.com/open-power/eCMD.git;branch=master;protocol=https"
Andrew Geisslercdd05fa2021-05-11 14:27:41 -05007SRCREV = "57b40102a54dac8b4b9cdc91beefd709d222867e"
Brad Bishopb3fceb32020-01-17 11:14:37 -05008DEPENDS += "zlib"
Joel Stanley7259c7d2019-11-04 23:43:51 +10309
Joel Stanley5f2105b2019-11-05 11:25:16 +103010SRC_URI += "file://croserver.service"
11
Joel Stanley7259c7d2019-11-04 23:43:51 +103012S = "${WORKDIR}/git"
13
Patrick Williams037f7bd2020-04-01 17:15:38 -050014inherit python3native
Andrew Geissler1878d702020-04-28 15:09:18 -050015DEPENDS += "${PYTHON_PN}-distro-native"
Brad Bishopb3fceb32020-01-17 11:14:37 -050016
Joel Stanley7259c7d2019-11-04 23:43:51 +103017do_configure() {
Patrick Williams037f7bd2020-04-01 17:15:38 -050018 LD="${CXX}" ${PYTHON} ${S}/config.py \
19 --without-swig --output-root ${B} --target obj \
20 --extensions "cmd cip" --build-verbose
Joel Stanley7259c7d2019-11-04 23:43:51 +103021}
22
23do_compile() {
24 cd ${S}/dllNetwork/server
25 oe_runmake
26}
27
28do_install() {
29 install -d ${D}${bindir}
30 install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
Joel Stanley5f2105b2019-11-05 11:25:16 +103031
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
Joel Stanley7259c7d2019-11-04 23:43:51 +103034}
Joel Stanley5f2105b2019-11-05 11:25:16 +103035
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000036FILES:${PN} += "${systemd_system_unitdir}/croserver.service"