blob: df4a3c67d59ca999a714eb4ae6ec23ab4d122953 [file] [log] [blame]
Patrick Venture998ff012018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Ventureffad0482018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture998ff012018-03-09 15:37:45 -08004PR = "r1"
Patrick Ventureffad0482018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture998ff012018-03-09 15:37:45 -08008
Patrick Ventured4c82372019-07-03 10:32:22 -07009inherit autotools pkgconfig
Patrick Venture998ff012018-03-09 15:37:45 -080010
Patrick Venture998ff012018-03-09 15:37:45 -080011inherit obmc-phosphor-ipmiprovider-symlink
Vijay Khemka09ad25b2019-06-20 14:37:11 -070012inherit systemd
Patrick Venture998ff012018-03-09 15:37:45 -080013
Patrick Ventureffad0482018-09-29 09:19:22 -070014S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060015SRC_URI = "git://github.com/openbmc/phosphor-pid-control;branch=master;protocol=https"
Andrew Geissler30308aa2022-01-19 23:30:08 +000016SRCREV = "d4fc570b5b0145aa4e9735f0764a258d339e38d3"
Patrick Ventureffad0482018-09-29 09:19:22 -070017
Patrick Venture998ff012018-03-09 15:37:45 -080018# Each platform will need a service file that starts
19# at an appropriate time per system. For instance, if
20# your system relies on passive dbus for fans or other
21# sensors then it may be prudent to wait for all of them.
22
23DEPENDS += "autoconf-archive-native"
Patrick Venture998ff012018-03-09 15:37:45 -080024DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -040025DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture998ff012018-03-09 15:37:45 -080026DEPENDS += "phosphor-logging"
27DEPENDS += "libevdev"
Patrick Venture4686bb52019-02-12 08:59:31 -080028DEPENDS += "nlohmann-json"
Patrick Venture0647c292019-03-11 08:45:12 -070029DEPENDS += "cli11"
Andrew Geissler3f2554c2019-04-15 14:22:02 +000030DEPENDS += "boost"
Patrick Venture998ff012018-03-09 15:37:45 -080031
Patrick Venture998ff012018-03-09 15:37:45 -080032# We depend on this to be built first so we can build our providers.
33DEPENDS += "phosphor-ipmi-host"
34
Vijay Khemka09ad25b2019-06-20 14:37:11 -070035SERVICE_FILE = "phosphor-pid-control.service"
36SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050037SYSTEMD_SERVICE:${PN} = "${SERVICE_FILE}"
Vijay Khemka09ad25b2019-06-20 14:37:11 -070038
39EXTRA_OECONF = " \
40 SYSTEMD_TARGET="multi-user.target" \
William A. Kennington IIIb05134b2021-06-04 17:51:28 -070041 --disable-tests \
Vijay Khemka09ad25b2019-06-20 14:37:11 -070042 "
43
Patrick Williams12fc9392021-08-06 09:16:53 -050044FILES:${PN} = "${bindir}/swampd ${bindir}/setsensor"
Patrick Venture998ff012018-03-09 15:37:45 -080045
Patrick Venture26f8c6c2018-07-27 07:27:01 -070046# The following installs the OEM IPMI handler for the fan controls.
Patrick Williams12fc9392021-08-06 09:16:53 -050047FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
48FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
49FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
50FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture998ff012018-03-09 15:37:45 -080051
Patrick Venture26f8c6c2018-07-27 07:27:01 -070052HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"
Brandon Kim627e5cd2020-08-13 14:51:02 -070053
54config_datadir="${datadir}/swampd/"
55# config_path is the location swampd expects to find a json configuration.
56# the file is expected to be named config.json
57config_path="${config_datadir}config.json"