blob: 8de3384ab5c6bb3887215911b11b0bdfe13910fc [file] [log] [blame]
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06005
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06006inherit phosphor-ipmi-fru
Matt Spinler0a8ea632017-12-14 13:31:55 -06007inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -06008inherit native
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06009
10SRC_URI += "file://config.yaml"
11
12DEPENDS += " \
13 mrw-native \
14 mrw-perl-tools-native \
15 "
16
17PROVIDES += "virtual/phosphor-ipmi-fru-properties"
18
19S = "${WORKDIR}"
20
21do_install() {
22 DEST=${D}${properties_datadir}
23 install -d ${DEST}
24
25 ${bindir}/perl-native/perl \
26 ${bindir}/gen_fru_properties.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060027 -m ${mrw_datadir}/${MRW_XML} \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060028 -c config.yaml \
Ratan Gupta338899a2017-03-30 14:32:02 +053029 -o ${DEST}/extra-properties.yaml
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060030}