blob: 4deaf0de17679df0fc22b7156fef22a999d98e45 [file] [log] [blame]
Tom Josephcf7e8492017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for non-mrw machines"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Tom Josephcf7e8492017-05-08 11:49:10 +05305
Tom Josephcf7e8492017-05-08 11:49:10 +05306inherit phosphor-ipmi-host
Joseph Reynolds79809ea2021-02-26 15:37:31 -06007inherit native
Tom Josephcf7e8492017-05-08 11:49:10 +05308
9PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe would provide the sample inventory to sensor config
17 # mapping, for non-mrw machines.
18
19 DEST=${D}${sensor_datadir}
20 install -d ${DEST}
21 install config.yaml ${DEST}/invsensor.yaml
22}