blob: 69bf0bce7fadbe829488888df7e7bc84106fdf69 [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit systemd
7inherit autotools pkgconfig
8
9HOMEPAGE = "https://github.com/openbmc/libmctp"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
Patrick Williamsbb99d222022-01-24 15:55:09 -060012SRC_URI = "git://github.com/openbmc/libmctp;branch=master;protocol=https \
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080013 file://default"
Andrew Geissler6f3f8db2022-01-10 01:50:15 +000014SRCREV = "56886e7f462d647682c59eb52ce49ae3c45abfdf"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080015
16DEPENDS += "autoconf-archive-native \
17 systemd \
George Liu948c7b42021-06-24 11:13:15 +080018 "
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080019
Patrick Williams12fc9392021-08-06 09:16:53 -050020SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
George Liu948c7b42021-06-24 11:13:15 +080021 mctp-demux.socket \
22 "
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080023
Brad Bishop959aa762021-12-03 15:55:30 -050024PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} pcap"
Andrew Jefferyd957f032021-05-12 22:31:34 +093025PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
26 --without-systemdsystemunitdir,systemd"
27
Andrew Jeffery8e0e67f2021-05-11 13:40:40 +093028PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
Brad Bishopf4f6f172021-12-02 15:09:01 -050029PACKAGECONFIG[pcap] = "--enable-capture,--disable-capture,libpcap,"
Andrew Jeffery8e0e67f2021-05-11 13:40:40 +093030
Patrick Williams12fc9392021-08-06 09:16:53 -050031CONFFILES:${PN} = "${sysconfdir}/default/mctp"
Andrew Jefferyd957f032021-05-12 22:31:34 +093032
Patrick Williams12fc9392021-08-06 09:16:53 -050033do_install:append() {
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080034 install -d ${D}${sysconfdir}/default
35 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
36}
37
38S = "${WORKDIR}/git"