blob: f5b56a34080483619d875772675a1a53a3b538e4 [file] [log] [blame]
George Hungbd21fb242020-08-03 13:39:03 +08001PR = "r1"
2PV = "1.0+git${SRCPV}"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
Patrick Williamsbb99d222022-01-24 15:55:09 -06006SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git;branch=master;protocol=https"
Harvey Wu22f97c82021-03-29 16:35:48 +08007SRCREV = "cadbe4801db76799e21b7bc9c405e5df9988dee0"
George Hungbd21fb242020-08-03 13:39:03 +08008S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11inherit meson
12
13DEPENDS += " nlohmann-json"
14DEPENDS += " sdbusplus"
George Hungbd21fb242020-08-03 13:39:03 +080015DEPENDS += " sdeventplus"
16DEPENDS += " phosphor-dbus-interfaces"
Willy Tuf3acf6d2021-08-10 18:14:20 -070017RDEPENDS:${PN} += " bash"
George Hungbd21fb242020-08-03 13:39:03 +080018
Willy Tuf3acf6d2021-08-10 18:14:20 -070019FILES:${PN} = "${bindir}/read-margin-temp"
George Hungbd21fb242020-08-03 13:39:03 +080020
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 read-margin-temp ${D}${bindir}
24}
25