blob: 79341b9d2926a56f79d5792eb75de565afef7c0f [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
Andrew Geisslera2681d92020-10-16 10:17:07 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
Brad Bishop5f78ea12019-09-10 07:20:03 -04005
Andrew Geisslera2681d92020-10-16 10:17:07 -05006SRC_URI[md5sum] = "b5bd0acec56ae7ccf5ac22d3f671c3a7"
7SRC_URI[sha256sum] = "6bb7f539903cb031fecb855b615cbcac8cd245ebc6fa51c6e23ab3386db89771"
Andrew Geissler89770b02020-06-13 10:40:47 -05008
9do_install_append() {
10 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
11 for f in $perm_files; do
12 chmod 644 "${f}"
13 done
14}
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
17UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
18
19BBCLASSEXTEND = "native nativesdk"
20inherit pypi ptest setuptools3
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
Andrew Geisslera2681d92020-10-16 10:17:07 -050026DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
27
Andrew Geissler89770b02020-06-13 10:40:47 -050028RDEPENDS_${PN} += " \
29 ${PYTHON_PN}-math \
30 ${PYTHON_PN}-html \
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050031 ${PYTHON_PN}-wcwidth \
Andrew Geissler89770b02020-06-13 10:40:47 -050032"
33
34RDEPENDS_${PN}-ptest += " \
35 ${PYTHON_PN}-pytest \
36"
37
38do_install_ptest() {
39 cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
40}