Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Dependency management tool for Golang" |
| 2 | HOMEPAGE = "https://github.com/golang/dep" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" |
| 5 | |
| 6 | GO_IMPORT = "github.com/golang/dep" |
| 7 | SRC_URI = "git://${GO_IMPORT} \ |
| 8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | file://0001-bolt_riscv64-Add-support-for-riscv64.patch;patchdir=src/github.com/golang/dep \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | " |
| 11 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 12 | SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | inherit go |
| 15 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 16 | # New Go versions has Go modules support enabled by default and cause the Glide |
| 17 | # tool build to fail. |
| 18 | export GO111MODULE = "off" |
| 19 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" |
| 21 | |
| 22 | RDEPENDS_${PN}-dev += "bash" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | # For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain. |
| 27 | # error message: vet config not found |
| 28 | PTEST_ENABLED_mips = "0" |
| 29 | PTEST_ENABLED_mips64 = "0" |