Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
| 5 | HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
| 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \ |
| 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "2a44676d28a87bbc232903d5d573e7618e4fae0cea3a1aff067a26fa66652b75" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | |
| 19 | inherit pkgconfig |
| 20 | |
| 21 | EXTRA_OEMAKE = "\ |
| 22 | -f '${S}/Makefile' \ |
| 23 | \ |
| 24 | 'PREFIX=${prefix}' \ |
| 25 | 'SBINDIR=${sbindir}' \ |
| 26 | 'MANDIR=${mandir}' \ |
| 27 | " |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake 'DESTDIR=${D}' install |
| 31 | } |