Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for sending desktop notifications to a notification daemon" |
| 2 | DESCRIPTION = "It sends desktop notifications to a notification daemon, as defined \ |
| 3 | in the Desktop Notifications spec. These notifications can be used to inform \ |
| 4 | the user about an event or display some form of information without getting \ |
| 5 | in the user's way." |
| 6 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/libnotify" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/libnotify/issues" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "LGPL-2.1-only" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
| 12 | DEPENDS = "dbus glib-2.0 gdk-pixbuf" |
| 13 | |
| 14 | PACKAGECONFIG ?= "" |
| 15 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gtk+3" |
| 16 | |
| 17 | GNOMEBASEBUILDCLASS = "meson" |
| 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 19 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 20 | GIR_MESON_DISABLE_FLAG = "disabled" |
| 21 | inherit gnomebase gtk-doc features_check gobject-introspection |
| 22 | # depends on gtk+3 if tests are enabled |
| 23 | ANY_OF_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'tests', '${GTK3DISTROFEATURES}', '', d)}" |
| 24 | |
| 25 | SRC_URI[archive.sha256sum] = "d033e6d4d6ccbf46a436c31628a4b661b36dca1f5d4174fe0173e274f4e62557" |
| 26 | |
| 27 | EXTRA_OEMESON = "-Dman=false" |
| 28 | |
| 29 | # there were times, we had two versions of libnotify (oe-core libnotify:0.6.x / |
| 30 | # meta-gnome libnotify3: 0.7.x) |
| 31 | PROVIDES += "libnotify3" |
| 32 | RPROVIDES:${PN} += "libnotify3" |
| 33 | RCONFLICTS:${PN} += "libnotify3" |
| 34 | RREPLACES:${PN} += "libnotify3" |
| 35 | |
| 36 | # -7381 is specific to the NodeJS bindings |
| 37 | CVE_CHECK_IGNORE += "CVE-2013-7381" |