Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "IPC library used by GnuPG and GPGME" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A small library implementing the so-called Assuan protocol. \ |
| 3 | This protocol is used for IPC between most newer GnuPG components. \ |
| 4 | Both, server and client side functions are provided. " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/" |
| 6 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 7 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-3.0-or-later & LGPL-2.1-or-later" |
| 9 | LICENSE:${PN} = "LGPL-2.1-or-later" |
| 10 | LICENSE:${PN}-doc = "GPL-3.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| 12 | file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 13 | file://src/assuan.c;endline=20;md5=ab92143a5a2adabd06d7994d1467ea5c\ |
| 14 | file://src/assuan-defs.h;endline=20;md5=15d950c83e82978e35b35e790d7e4d39" |
| 15 | |
| 16 | DEPENDS = "libgpg-error" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 19 | SRC_URI = "${GNUPG_MIRROR}/libassuan/libassuan-${PV}.tar.bz2 \ |
| 20 | file://libassuan-add-pkgconfig-support.patch \ |
| 21 | " |
| 22 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 23 | SRC_URI[sha256sum] = "8e8c2fcc982f9ca67dcbb1d95e2dc746b1739a4668bc20b3a3c5be632edb34e4" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | BINCONFIG = "${bindir}/libassuan-config" |
| 26 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | inherit autotools texinfo binconfig-disabled pkgconfig multilib_header |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | do_configure:prepend () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | # Else these could be used in preference to those in aclocal-copy |
| 31 | rm -f ${S}/m4/*.m4 |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_install:append () { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | oe_multilib_header assuan.h |
| 36 | } |
| 37 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | BBCLASSEXTEND = "native nativesdk" |