blob: 5f62b9e5cdffef4dd620572c6a3d7d4b4d842cd2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "a4fd427ee2acc5a8f5fb030bf7816917cee63bd8"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
Brad Bishopc64341c2019-03-25 13:14:15 -040013 file://0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014"
15
16inherit distro_features_check
17REQUIRED_DISTRO_FEATURES = "x11 systemd"
18
19inherit setuptools3 python3native
20
21RDEPENDS_${PN} = "python3-pygobject python3 \
22 python3-blivet gtk+3 \
23 python3-pid libreport \
24"
25
26FILES_${PN} += " \
27 ${datadir}/* \
28 "