Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "SM: Session Management library" |
| 2 | |
| 3 | DESCRIPTION = "The Session Management Library (SMlib) is a low-level \"C\" \ |
| 4 | language interface to XSMP. The purpose of the X Session Management \ |
| 5 | Protocol (XSMP) is to provide a uniform mechanism for users to save and \ |
| 6 | restore their sessions. A session is a group of clients, each of which \ |
| 7 | has a particular state." |
| 8 | |
| 9 | require xorg-lib-common.inc |
| 10 | |
| 11 | LICENSE = "MIT-style" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d" |
| 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS += "libice xorgproto xtrans" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | |
| 16 | # libSM can work without libuuid, we explicitly disable it to break the following circular dependency |
| 17 | # when DISTRO_FEATURES contains 'systemd' and 'x11'. |
| 18 | # systemd -> dbus -> libsm -> util-linux -> systemd |
| 19 | EXTRA_OECONF += "--without-libuuid" |
| 20 | |
| 21 | PE = "1" |
| 22 | |
| 23 | XORG_PN = "libSM" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |
| 26 | |
| 27 | SRC_URI[md5sum] = "499a7773c65aba513609fe651853c5f3" |
| 28 | SRC_URI[sha256sum] = "0baca8c9f5d934450a70896c4ad38d06475521255ca63b717a6510fdb6e287bd" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 29 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 31 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |