blob: 7e14ece93d13cff8c8c6ba13bfe3682a76e1a1ed [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006PR = "r33"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10inherit packagegroup distro_features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011REQUIRED_DISTRO_FEATURES = "x11"
12
13PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
14
15RDEPENDS_${PN} = "\
16 ${PN}-base \
17 ${PN}-apps \
18 ${PN}-games \
19 "
20
21NETWORK_MANAGER ?= "connman-gnome"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23SUMMARY_${PN}-base = "Sato desktop - base packages"
24RDEPENDS_${PN}-base = "\
25 matchbox-desktop \
26 matchbox-session-sato \
27 matchbox-keyboard \
28 matchbox-keyboard-applet \
29 matchbox-keyboard-im \
30 matchbox-config-gtk \
31 xcursor-transparent-theme \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034 shutdown-desktop \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 ${NETWORK_MANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'udev-extraconf', d)} \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050037 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038 "
39
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040FILEMANAGER ?= "pcmanfm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041
42WEB ?= ""
43#WEB = "epiphany"
44
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045GSTEXAMPLES ?= "gst-examples"
46GSTEXAMPLES_riscv64 = ""
47
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048SUMMARY_${PN}-apps = "Sato desktop - applications"
49RDEPENDS_${PN}-apps = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060050 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051 matchbox-terminal \
52 sato-screenshot \
53 ${FILEMANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 ${GSTEXAMPLES} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 ${WEB} \
56 "
57
58SUMMARY_${PN}-games = "Sato desktop - games"
59RDEPENDS_${PN}-games = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060060 puzzles \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061 "