Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Extremely Fast Compression algorithm" |
| 2 | DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems." |
| 3 | HOMEPAGE = "https://github.com/lz4/lz4" |
| 4 | |
| 5 | LICENSE = "BSD-2-Clause | GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=5cd5f851b52ec832b10eedb3f01f885a \ |
| 7 | file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://LICENSE;md5=c5cc3cd6f9274b4d32988096df9c3ec3 \ |
| 9 | " |
| 10 | |
| 11 | PE = "1" |
| 12 | |
| 13 | SRCREV = "5ff839680134437dbf4678f3d0c7b371d84f4964" |
| 14 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/lz4/lz4.git;branch=release;protocol=https \ |
| 16 | file://run-ptest \ |
| 17 | " |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 18 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 22 | inherit ptest |
| 23 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 24 | CVE_STATUS[CVE-2014-4715] = "fixed-version: Fixed in r118, which is larger than the current version." |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 25 | |
| 26 | EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' CFLAGS='${CFLAGS}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no" |
| 27 | |
| 28 | do_install() { |
| 29 | oe_runmake install |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 33 | |
| 34 | RDEPENDS:${PN}-ptest += "bash" |
| 35 | |
| 36 | do_compile_ptest() { |
| 37 | oe_runmake -C ${B}/tests/ |
| 38 | } |
| 39 | |
| 40 | do_install_ptest() { |
| 41 | install -d ${D}${PTEST_PATH}/tests/ |
| 42 | install --mode=755 ${B}/tests/frametest ${D}${PTEST_PATH}/tests/ |
| 43 | sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/run-ptest |
| 44 | |
| 45 | } |
| 46 | |