blob: c66c93ec5a28feb64174bd9c8deb3fd569eb9459 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LICENSE = "GPL-2.0+ & LGPL-2.1+"
Brad Bishope42b3e32020-01-15 22:08:42 -05005
6LIC_FILES_CHKSUM = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007 file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
8 file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -05009"
10
11SRC_URI = " \
12 git://linuxtv.org/libcamera.git;protocol=git \
Brad Bishope42b3e32020-01-15 22:08:42 -050013"
14
Andrew Geisslerc87764f2020-06-27 00:16:32 -050015SRCREV = "5f2f9406cebc668f0d69007d1ea59ef3c56ef28c"
Brad Bishope42b3e32020-01-15 22:08:42 -050016
Andrew Geisslerc87764f2020-06-27 00:16:32 -050017PV = "202006+git${SRCPV}"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19S = "${WORKDIR}/git"
20
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native"
Brad Bishope42b3e32020-01-15 22:08:42 -050022DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
23
24RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
25
26inherit meson pkgconfig python3native
27
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050028do_install_append() {
29 chrpath -d ${D}${libdir}/libcamera.so
30}
31
32addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata
33do_recalculate_ipa_signatures_package() {
34 local modules
35 for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
36 module="${module%.sign}"
37 if [ -f "${module}" ] ; then
38 modules="${modules} ${module}"
39 fi
40 done
41
42 ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
43}
44
Brad Bishope42b3e32020-01-15 22:08:42 -050045FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
46FILES_${PN} += " ${libdir}/libcamera.so"
47