Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Open-LLDP" |
| 2 | DESCRIPTION = "Link Layer Discovery Protocol for Linux that includes support for DCBX" |
| 3 | HOMEPAGE = "http://open-lldp.org/start" |
| 4 | |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit pkgconfig autotools |
| 11 | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} |
| 12 | |
| 13 | DEPENDS = "libnl libconfig readline" |
| 14 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 15 | SRCREV = "b71bfb87fefb31c4b1a6a7ae351791c90966c3a8" |
| 16 | PV .= "+git${SRCPV}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | SRC_URI = "git://github.com/intel/openlldp.git;protocol=https;branch=master \ |
| 18 | file://0001-Fix-musl-libc-build-issue.patch \ |
| 19 | file://0001-autotools-Add-include-path-to-generated-version.h.patch \ |
| 20 | file://0001-autotools-Add-option-to-disable-installation-of-syst.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 21 | file://0001-cmds-fix-enum-conversion.patch \ |
| 22 | file://0002-lldp_head-rename-and-make-extern.patch \ |
| 23 | file://0003-lldp-add-packed-struct-definition.patch \ |
| 24 | file://0004-lldptool-make-extern.patch \ |
| 25 | file://0005-cisco_oui-match-encode-handler-prototypes.patch \ |
| 26 | file://0006-ecp22-make-enum-a-type-rather-than-instance.patch \ |
| 27 | file://0007-lldp_8021qaz-extern-config-object.patch \ |
| 28 | file://0008-stringops-fix-some-string-copy-errors.patch \ |
| 29 | file://0009-8021qaz-mark-prio-map-functions-static.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | " |
| 31 | |
| 32 | # Makefile.am adds -Werror to AM_CFLAGS. There are warnings so disable it. |
| 33 | TARGET_CFLAGS += "-Wno-error" |
| 34 | |
| 35 | # Enable install of systemd conf files. |
| 36 | EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_system_unitdir}', '', d)}" |
| 37 | |
| 38 | SYSTEMD_SERVICE_${PN} = "lldpad.service lldpad.socket" |
| 39 | |
| 40 | # To enable service at boot set to enable in local.conf. |
| 41 | SYSTEMD_AUTO_ENABLE ?= "disable" |
| 42 | |
| 43 | RRECOMMENDS_${PN} = "iproute2-tc" |