blob: 7831dd95649d4093126ba3f5404edc3cce8cb470 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013SRCREV = "871a07001c64cfce15dffd7e93a5c3d55af6d5e8"
Brad Bishop19323692019-04-05 15:28:33 -040014S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020 gperf-native \
21 json-c \
22 nettle \
Brad Bishop19323692019-04-05 15:28:33 -040023"
24
Brad Bishop26bdd442019-08-16 17:08:17 -040025PACKAGES += "python3-${BPN}"
26FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
Brad Bishop19323692019-04-05 15:28:33 -040027
28PACKAGECONFIG ??= "python3 rpm"
Brad Bishop19323692019-04-05 15:28:33 -040029PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
30PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
31
32do_configure_prepend() {
33 ${S}/gen-version
34}