blob: aa5fe019d5c8a270a54078988d8326bdc510e01d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
5
6inherit xfce-panel-plugin
7
8SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89"
9SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch \
11 file://0001-Fix-multiple-definition-errors-under-GCC-10.0.patch \
12 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14EXTRA_OECONF = " \
15 --disable-procacpi \
16 --disable-xnvctrl \
17"
18
19do_configure_prepend() {
20 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
21}
22
23PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
24PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
25PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
26PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
27
28FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"