blob: 3928c8a4ac7ce92169730b0649a3e0bbf19cd727 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Class for packagegroup (package group) recipes
2
3# By default, only the packagegroup package itself is in PACKAGES.
4# -dbg and -dev flavours are handled by the anonfunc below.
5# This means that packagegroup recipes used to build multiple packagegroup
6# packages have to modify PACKAGES after inheriting packagegroup.bbclass.
7PACKAGES = "${PN}"
8
9# By default, packagegroup packages do not depend on a certain architecture.
10# Only if dependencies are modified by MACHINE_FEATURES, packages
11# need to be set to MACHINE_ARCH after inheriting packagegroup.bbclass
12PACKAGE_ARCH ?= "all"
13
14# Fully expanded - so it applies the overrides as well
15PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
16
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017LICENSE ?= "MIT"
18
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED', True) == 'all', 'allarch', '')}
20
21# This automatically adds -dbg and -dev flavours of all PACKAGES
22# to the list. Their dependencies (RRECOMMENDS) are handled as usual
23# by package_depchains in a following step.
24# Also mark all packages as ALLOW_EMPTY
25python () {
26 packages = d.getVar('PACKAGES', True).split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 if d.getVar('PACKAGEGROUP_DISABLE_COMPLEMENTARY', True) != '1':
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028 types = ['', '-dbg', '-dev']
29 if bb.utils.contains('DISTRO_FEATURES', 'ptest', True, False, d):
30 types.append('-ptest')
31 packages = [pkg + suffix for pkg in packages
32 for suffix in types]
33 d.setVar('PACKAGES', ' '.join(packages))
34 for pkg in packages:
35 d.setVar('ALLOW_EMPTY_%s' % pkg, '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036}
37
38# We don't want to look at shared library dependencies for the
39# dbg packages
40DEPCHAIN_DBGDEFAULTDEPS = "1"
41
42# We only need the packaging tasks - disable the rest
43do_fetch[noexec] = "1"
44do_unpack[noexec] = "1"
45do_patch[noexec] = "1"
46do_configure[noexec] = "1"
47do_compile[noexec] = "1"
48do_install[noexec] = "1"
49do_populate_sysroot[noexec] = "1"
50
51python () {
52 initman = d.getVar("VIRTUAL-RUNTIME_init_manager", True)
53 if initman and initman in ['sysvinit', 'systemd'] and not bb.utils.contains('DISTRO_FEATURES', initman, True, False, d):
54 bb.fatal("Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (%s) matches the entries enabled in DISTRO_FEATURES" % initman)
55}
56