blob: ff8254cfcdb33ea73d3bd7232abaf73684423437 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Helper tool used when compiling"
2DESCRIPTION = "pkg-config is a helper tool used when compiling applications and libraries. It helps determined \
3the correct compiler/link options. It is also language-agnostic."
4HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
5BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=pkg-config"
6SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11DEPENDS = "glib-2.0"
12DEPENDS_class-native = ""
13DEPENDS_class-nativesdk = ""
14
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015SRCREV = "87152c05be88ca8be71a3a563f275b3686d32c28"
16PV = "0.29.1+git${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017
18SRC_URI = "git://anongit.freedesktop.org/pkg-config \
19 file://pkg-config-native.in \
20 file://fix-glib-configure-libtool-usage.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021 file://0001-gdate-Move-warning-pragma-outside-of-function.patch \
22 file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024
25S = "${WORKDIR}/git"
26
27inherit autotools
28
29EXTRA_OECONF = "--without-internal-glib"
30EXTRA_OECONF_class-native = "--with-internal-glib"
31EXTRA_OECONF_class-nativesdk = "--with-internal-glib"
32
33acpaths = "-I ."
34
35BBCLASSEXTEND = "native nativesdk"
36
37# Set an empty dev package to ensure the base PN package gets
38# the pkg.m4 macros, pkgconfig does not deliver any other -dev
39# files.
40FILES_${PN}-dev = ""
41FILES_${PN} += "${datadir}/aclocal/pkg.m4"
42
43# When using the RPM generated automatic package dependencies, some packages
44# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by
45# specifying an appropriate provide.
46RPROVIDES_${PN} += "pkgconfig(pkg-config)"
47
48# Install a pkg-config-native wrapper that will use the native sysroot instead
49# of the MACHINE sysroot, for using pkg-config when building native tools.
50do_install_append_class-native () {
51 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
52 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
53 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native
54 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native
55}