blob: f1b0e92b2bb7b0b171b87d10dfd0b91d36155b15 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
Andrew Geissler82c905d2020-04-13 13:39:40 -05003HOMEPAGE = "https://01.org/powertop/"
4BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
Brad Bishop19323692019-04-05 15:28:33 -04005DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
Andrew Geisslerc182c622020-05-15 14:13:32 -05009SRC_URI = "git://github.com/fenrus75/powertop;protocol=https \
Brad Bishop08902b02019-08-20 09:16:51 -040010 file://0001-wakeup_xxx.h-include-limits.h.patch \
Brad Bishop19323692019-04-05 15:28:33 -040011"
Andrew Geisslerc182c622020-05-15 14:13:32 -050012SRCREV = "e8765b5475b22b7a2b6e9e8a031c68a268a0b0b3"
Brad Bishop19323692019-04-05 15:28:33 -040013
Andrew Geisslerc182c622020-05-15 14:13:32 -050014S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -040015
16inherit autotools gettext pkgconfig
17
Brad Bishop19323692019-04-05 15:28:33 -040018# we do not want libncursesw if we can
19do_configure_prepend() {
20 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
21 sed -i -e "s/ncursesw//g" ${S}/configure.ac
22 mkdir -p ${B}/src/tuning/
Andrew Geisslerc182c622020-05-15 14:13:32 -050023 echo "${PV}" > ${S}/version-long
24 echo "${PV}" > ${S}/version-short
Brad Bishop19323692019-04-05 15:28:33 -040025}
26
27inherit update-alternatives
28ALTERNATIVE_${PN} = "powertop"
29ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
30ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_PRIORITY = "100"