blob: 19bbf03f1d7785cc89670197e7e22784991ebe52 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0+ & LGPL-2.1+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
Brad Bishopc342db32019-05-15 21:57:59 -040016UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/traceroute/"
17
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
19 file://filter-out-the-patches-from-subdirs.patch \
20"
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022SRC_URI[md5sum] = "84d329d67abc3fb83fc8cb12aeaddaba"
23SRC_URI[sha256sum] = "3669d22a34d3f38ed50caba18cd525ba55c5c00d5465f2d20d7472e5d81603b6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
25EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
26
27do_compile() {
28 export LDFLAGS="${TARGET_LDFLAGS} -L${S}/libsupp"
29 oe_runmake "env=yes"
30}
31
32do_install() {
33 install -d ${D}${bindir}
34 install -m755 ${BPN}/${BPN} ${D}${bindir}
35
36 install -m755 wrappers/tcptraceroute ${D}${bindir}
37
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038 install -d ${D}${mandir}/man8
39 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}/man8
40 ln -s ${BPN}.8 ${D}${mandir}/man8/${BPN}6.8
41 ln -s ${BPN}.8 ${D}${mandir}/man8/tcptraceroute.8
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042
43}
44
45ALTERNATIVE_PRIORITY = "60"
46ALTERNATIVE_${PN} = "traceroute"
47ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"