blob: 26b03814d69ad237bac391c00d2bccf4b25e78e0 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An IP address pool manager"
2DESCRIPTION = "IpPool is implemented as a separate server daemon \
3to allow any application to use its address pools. This makes it possible \
4to define address pools that are shared by PPP, L2TP, PPTP etc. It may be \
5useful in some VPN server setups. IpPool comes with a command line \
6management application, ippoolconfig to manage and query address pool \
7status. A pppd plugin is supplied which allows pppd to request IP \
8addresses from ippoold. \
9"
10HOMEPAGE = "http://www.openl2tp.org/"
11SECTION = "console/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-2.0-or-later"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013
14SRC_URI = "https://sourceforge.net/projects/openl2tp/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz \
15 file://runtest.sh \
16 file://ippool.service \
17 file://ippool_usl_timer.patch \
18 file://ippool_parallel_make_and_pic.patch \
19 file://ippool_init.d.patch \
20 file://always_syslog.patch \
21 file://makefile-add-ldflags.patch \
22 file://0001-usl_timer-Check-for-return-value-of-write-API.patch \
23 file://0001-Respect-flags-from-env.patch \
24 file://0001-read-returns-ssize_t.patch \
25 file://0002-Mark-first-element-of-a-string-as-null.patch \
26 file://0003-cli-Mark-return-of-strtol-as-long-int.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027 file://0002-link-with-libtirpc.patch \
28 file://0003-musl-fixes.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050029 file://strncpy-truncation.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050030 file://0001-pppd-ippool.c-Fix-type-casting-issues-between-in_add.patch \
31 file://0002-ippool_rpc_server.c-Add-missing-prototype-for-ippool.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060032 file://0001-Use-unsigned-int-type-for-1-bit-integer-bitfield.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 "
34
35LIC_FILES_CHKSUM = "file://LICENSE;md5=4c59283b82fc2b166455e0fc23c71c6f"
36SRC_URI[md5sum] = "e2401e65db26a3764585b97212888fae"
37SRC_URI[sha256sum] = "d3eab7d6cad5da8ccc9d1e31d5303e27a39622c07bdb8fa3618eea314412075b"
38
39inherit systemd
40
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc"
Patrick Williams213cb262021-08-07 19:21:33 -050042RDEPENDS:${PN} = "rpcbind"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
44EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
45EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
46# enable self tests
47EXTRA_OEMAKE += "IPPOOL_TEST=y"
48
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050050
Patrick Williams213cb262021-08-07 19:21:33 -050051SYSTEMD_SERVICE:${PN} = "ippool.service"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050052SYSTEMD_AUTO_ENABLE = "disable"
53
54
Patrick Williams213cb262021-08-07 19:21:33 -050055do_compile:prepend() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056 # fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
57 sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
58 sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
59
60 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile
61
62}
63
64
65do_install() {
66 oe_runmake DESTDIR=${D} install
67
68 install -D -m 0755 ${S}/debian/init.d ${D}${sysconfdir}/init.d/ippoold
69 install -D -m 0644 ${WORKDIR}/ippool.service ${D}${systemd_system_unitdir}/ippool.service
70 sed -i -e 's:@SBINDIR@:${sbindir}:g' ${D}${systemd_system_unitdir}/ippool.service
71
72 # install self test
73 install -d ${D}/opt/${BPN}
74 install ${S}/test/all.tcl ${S}/test/ippool.test \
75 ${S}/test/test_procs.tcl ${D}/opt/${BPN}
76 install ${WORKDIR}/runtest.sh ${D}/opt/${BPN}
77 # fix the ../ippoolconfig in test_procs.tcl
78 sed -i -e "s:../ippoolconfig:ippoolconfig:" \
79 ${D}/opt/${BPN}/test_procs.tcl
80}
81
82
83PACKAGES =+ "${PN}-test"
84
Patrick Williams213cb262021-08-07 19:21:33 -050085FILES:${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
86FILES:${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
87FILES:${PN}-test = "/opt/${BPN}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088
89# needs tcl to run tests
Patrick Williams213cb262021-08-07 19:21:33 -050090RDEPENDS:${PN}-test += "tcl ${BPN}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050091
92PPPD_VERSION="${@get_ppp_version(d)}"
93
94def get_ppp_version(d):
95 import re
96
97 pppd_plugin = d.expand('${STAGING_LIBDIR}/pppd')
98 if not os.path.isdir(pppd_plugin):
99 return None
100
101 bb.debug(1, "pppd plugin dir %s" % pppd_plugin)
Andrew Geissler595f6302022-01-24 19:11:47 +0000102 r = re.compile(r"\d*\.\d*\.\d*")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500103 for f in os.listdir(pppd_plugin):
104 if os.path.isdir(os.path.join(pppd_plugin, f)):
105 ma = r.match(f)
106 if ma:
107 bb.debug(1, "pppd version dir %s" % f)
108 return f
109 else:
110 bb.debug(1, "under pppd plugin dir %s" % f)
111
112 return None
113