blob: 11c4037b230da8f6d3159a87cb030a495d9f1f8b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "User-space front-end command-line tool for ftrace"
2
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = " \
5 file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
6 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd \
7 "
8
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;branch=master \
10 file://0001-Replace-LFS64-interfaces-off64_t-and-lseek64.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060011 file://0002-Drop-using-_LARGEFILE64_SOURCE.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 file://0001-Do-not-emit-useless-rpath.patch"
13SRCREV = "18233e4c32857cb7ddd4960beeec8360ed834fc5"
14
15S = "${WORKDIR}/git"
16
17DEPENDS += "libtraceevent libtracefs zstd xmlto-native asciidoc-native swig-native bison-native flex-native"
18
19inherit pkgconfig bash-completion
20
21TARGET_CC_ARCH += "${LDFLAGS}"
22
23do_compile() {
24 oe_runmake libdir_relative=${BASELIB} libs
25 oe_runmake libdir_relative=${BASELIB} all
26}
27
28do_install() {
Andrew Geisslerc5535c92023-01-27 16:10:19 -060029 oe_runmake libdir_relative=${baselib} etcdir=${sysconfdir} pkgconfig_dir=${libdir}/pkgconfig DESTDIR=${D} install install_libs
Andrew Geissler517393d2023-01-13 08:55:19 -060030 # Because makefile uses cp instead of install we need to change owner of files
31 chown -R root:root ${D}${libdir}
32}