blob: 80869d0163e13d27be8cc0133e6f5e224580996f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Provides modules to easily parse localized dates in almost any string formats commonly found on web pages"
2HOMEPAGE = "https://github.com/scrapinghub/dateparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3d3ed25571191e7aa3f55d0a6efe0051"
5
Andrew Geisslerc5535c92023-01-27 16:10:19 -06006SRC_URI[sha256sum] = "e703db1815270c020552f4b3e3a981937b48b2cbcfcef5347071b74788dd9214"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8PYPI_PACKAGE = "dateparser"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-tzlocal \
17 ${PYTHON_PN}-ruamel-yaml \
18"
19
20# Ommitted ${PYTHON_PN}-convertdate, ${PYTHON_PN}-jdatetime ${PYTHON_PN}-umalqurra