blob: d01b7486d97cf976c641009f10d2f384edb17179 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Line-oriented text editor"
2HOMEPAGE = "http://www.gnu.org/software/ed/"
3DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands."
4
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
Andrew Geisslerc5535c92023-01-27 16:10:19 -06007 file://ed.h;endline=20;md5=504a90a78b045972e2fd2f3fc418c195 \
8 file://main.c;endline=17;md5=cf9d322b0ac4445ca2299c61ee175365 \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009 "
10
11SECTION = "base"
12
13CVE_PRODUCT = "gnu:ed"
14
15# LSB states that ed should be in /bin/
16bindir = "${base_bindir}"
17
18# Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/
19SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz"
20UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/"
21
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022SRC_URI[sha256sum] = "ce2f2e5c424790aa96d09dacb93d9bbfdc0b7eb6249c9cb7538452e8ec77cd48"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26inherit texinfo
27
28do_configure() {
29 ${S}/configure
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34 # Info dir listing isn't interesting at this point so remove it if it exists.
35 if [ -e "${D}${infodir}/dir" ]; then
36 rm -f ${D}${infodir}/dir
37 fi
38}