blob: 014ae2ef1c786dc6c265bd2dd88fd8596b7fcfa7 [file] [log] [blame]
Patrick Venturec57ab162018-09-22 18:56:00 -07001SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats"
17SRCREV = "d26fff4ecd74aa72433bcb547d95029e4b7b0eb3"
18
19FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
23
24HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"