Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)." |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | SRC_URI = "git://github.com/rpm-software-management/libcomps.git \ |
| 6 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 7 | file://0002-Set-library-installation-path-correctly.patch \ |
| 8 | file://0001-Make-__comps_objmrtree_all-static-inline.patch \ |
| 9 | " |
| 10 | |
| 11 | PV = "0.1.8+git${SRCPV}" |
| 12 | SRCREV = "01a4759894cccff64d2561614a58281adf5ce859" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake distutils3-base |
| 17 | |
| 18 | DEPENDS += "libxml2 expat libcheck" |
| 19 | |
| 20 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" |
| 21 | OECMAKE_SOURCEPATH = "${S}/libcomps" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
| 24 | |