blob: 29cd43e89a4ef835b4f83fe0280b2a75b263ae5e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
Brad Bishop08902b02019-08-20 09:16:51 -040011require glibc-version.inc
12
Brad Bishop19323692019-04-05 15:28:33 -040013# Tell autotools that we're working in the localedef directory
14#
15AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
16
17inherit native
18inherit autotools
19
20FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
21
Brad Bishop19323692019-04-05 15:28:33 -040022SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
23 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
24 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
25 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
26 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
27 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
28 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
29 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
30 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
31 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
32 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
Brad Bishopc68388fc2019-08-26 01:33:31 -040033 file://add-cross-localedef-hardlink.patch \
34 file://allow-compile-separate-from-util-linux-hardlink.patch \
Brad Bishop19323692019-04-05 15:28:33 -040035"
36# Makes for a rather long rev (22 characters), but...
37#
38SRCREV_FORMAT = "glibc_localedef"
39
40S = "${WORKDIR}/git"
41
42EXTRA_OECONF = "--with-glibc=${S}"
43CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
44
45do_install() {
46 install -d ${D}${bindir}
47 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
Brad Bishopc68388fc2019-08-26 01:33:31 -040048 install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
Brad Bishop19323692019-04-05 15:28:33 -040049}