blob: 647516cf9240dbec8f61c7dd5d48ac074b945581 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
Brad Bishop08902b02019-08-20 09:16:51 -040017SRCREV = "9a85732d8beaae4b80cab98bb3355660389c1d36"
Brad Bishopc342db32019-05-15 21:57:59 -040018SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
21
22inherit autotools-brokensep pkgconfig manpages distutils3-base
23
24CLEANBROKEN = "1"
25
26PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
Brad Bishopc68388fc2019-08-26 01:33:31 -040027PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
28
Brad Bishopc342db32019-05-15 21:57:59 -040029EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
Brad Bishop15ae2502019-06-18 21:44:24 -040030EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
31EXTRA_PYTHON_CFLAGS_class-native = ""
32EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
33EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
Brad Bishopc342db32019-05-15 21:57:59 -040034
35do_configure_prepend() {
36 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
37 mkdir -p ${S}/config
38 cp -f $(automake --print-libdir)/install-sh ${S}/config/
39}
40
41S = "${WORKDIR}/git"
42
43do_install_append() {
44 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
45}
46
47BBCLASSEXTEND = "native"