blob: faafbc1572c0972781077d6d9891d7d8799ad262 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
Brad Bishopc68388fc2019-08-26 01:33:31 -04009SRC_URI[md5sum] = "2ba0a3b76d39ccd90ca22bfa82fc635f"
10SRC_URI[sha256sum] = "e05103825871e210d50a44c7e448587b0ed99dd775d3ef586304c58f40224a53"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28"
29
30BBCLASSEXTEND = "native nativesdk"