blob: ff4a9d06108c34b1b86bebfdcacfe611f5ab3db1 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
Brad Bishopc342db32019-05-15 21:57:59 -040010RDEPENDS_${PN}_class-target = " \
11 perl-module-carp \
12 perl-module-exporter \
13 perl-module-exporter-heavy \
14 perl-module-dynaloader \
Brad Bishop19323692019-04-05 15:28:33 -040015"
16
17LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
18
19SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
20SRC_URI[md5sum] = "f2ba18b5cea1c8cb322a62be0a847f3d"
21SRC_URI[sha256sum] = "3f2025023a56286cebd15cb495e36ccd9b456c3cc229bf2ce1f69e9ebfc27f5d"
22
23S = "${WORKDIR}/DBI-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_prepend() {
28 # test requires "-T" (taint) command line option
29 rm -rf ${B}/t/pod-coverage.t
30 rm -rf ${B}/t/13taint.t
31 # source of test failure not obvious
32 rm -rf ${B}/t/85gofer.t
33 # unclear why there are several duplicates of tests in tarball
34 rm -rf ${B}/t/z*.t
35}
36
37BBCLASSEXTEND = "native"