blob: e2305d096a4da72f329ddb8f8f75b42369acd8b6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
17 file://0001-libopkg-add-add-ignore-recommends-option.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040018 file://0001-regress-issue72.py-resolve-paths-before-comparision.patch \
19 file://0001-opkg-add-target-for-testsuite-installation.patch \
20 file://run-ptest \
Brad Bishop19323692019-04-05 15:28:33 -040021"
22
23SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5"
24SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe"
25
Brad Bishopc342db32019-05-15 21:57:59 -040026# This needs to be before ptest inherit, otherwise all ptest files end packaged
27# in libopkg package if OPKGLIBDIR == libdir, because default
28# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
29PACKAGES =+ "libopkg"
30
31inherit autotools pkgconfig systemd ptest
Brad Bishop19323692019-04-05 15:28:33 -040032
33target_localstatedir := "${localstatedir}"
34OPKGLIBDIR = "${target_localstatedir}/lib"
35
36PACKAGECONFIG ??= "libsolv"
37
38PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
39PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
40PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
41PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
42PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
43PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
44PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
45
46EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
47
48do_install_append () {
49 install -d ${D}${sysconfdir}/opkg
50 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
51 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
52
53 # We need to create the lock directory
54 install -d ${D}${OPKGLIBDIR}/opkg
55}
56
57RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
58RDEPENDS_${PN}_class-native = ""
59RDEPENDS_${PN}_class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040060RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression"
Brad Bishop19323692019-04-05 15:28:33 -040061RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
62RCONFLICTS_${PN} = "opkg-collateral"
63RPROVIDES_${PN} = "opkg-collateral"
64
Brad Bishop19323692019-04-05 15:28:33 -040065FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
66
67BBCLASSEXTEND = "native nativesdk"
68
69CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"