blob: 6f5acd4c75aa294658e5ee063693d6e0215a1384 [file] [log] [blame]
Stanley Chuc28310e2020-06-18 14:04:42 +08001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
David Wang026925d2021-08-13 11:39:20 +080010RDEPENDS:${PN} += "bash"
Stanley Chuc28310e2020-06-18 14:04:42 +080011
12SRC_URI = " file://hotswap-power-cycle.service"
13
14do_install() {
15 install -d ${D}${systemd_system_unitdir}
16 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir}
17}
18
19SYSTEMD_PACKAGES = "${PN}"
David Wang026925d2021-08-13 11:39:20 +080020SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service"
Stanley Chuc28310e2020-06-18 14:04:42 +080021