Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Collection of simple PIN or passphrase entry dialogs" |
| 2 | DESCRIPTION = "\ |
| 3 | Pinentry is a collection of simple PIN or passphrase entry dialogs which \ |
| 4 | utilize the Assuan protocol as described by the aegypten project; see \ |
| 5 | http://www.gnupg.org/aegypten/ for details." |
| 6 | |
| 7 | HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e" |
| 10 | |
| 11 | DEPENDS = "gettext-native libassuan libgpg-error" |
| 12 | |
| 13 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 14 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 15 | file://libassuan_pkgconf.patch \ |
| 16 | file://gpg-error_pkconf.patch \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[sha256sum] = "10072045a3e043d0581f91cd5676fcac7ffee957a16636adedaa4f583a616470" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | PACKAGECONFIG ??= "ncurses libcap" |
| 24 | |
| 25 | PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses" |
| 26 | PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap" |
| 27 | PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase" |
| 28 | PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0" |
| 29 | |
| 30 | PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret" |
| 31 | |
| 32 | EXTRA_OECONF = " \ |
| 33 | --disable-rpath \ |
| 34 | " |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 35 | EXTRA_OECONF:append:libc-musl = " \ |
| 36 | ac_cv_should_define__xopen_source=yes \ |
| 37 | " |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |