blob: 8b36a8ebde727159709b80eb1c4764d364093786 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
Andrew Geissler475cb722020-07-10 16:00:51 -05007# Includes opennsh and xxhash dynamic link exception
Brad Bishop316dfdd2018-06-25 12:45:53 -04008LICENSE = "GPLv3+"
Andrew Geissler475cb722020-07-10 16:00:51 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060016 file://determism.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050017 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerc9f78652020-09-18 14:11:35 -050019SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geissler82c905d2020-04-13 13:39:40 -050021# -16548 required for v3.1.3pre1. Already in v3.1.3.
22CVE_CHECK_WHITELIST += " CVE-2017-16548 "
23
Andrew Geissler475cb722020-07-10 16:00:51 -050024inherit autotools-brokensep
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
Brad Bishop316dfdd2018-06-25 12:45:53 -040026PACKAGECONFIG ??= "acl attr \
27 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
28"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Brad Bishop316dfdd2018-06-25 12:45:53 -040030PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
31PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler475cb722020-07-10 16:00:51 -050033PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
34PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
35PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
Brad Bishop316dfdd2018-06-25 12:45:53 -040037
38# By default, if crosscompiling, rsync disables a number of
39# capabilities, hardlinking symlinks and special files (i.e. devices)
40CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
41
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042EXTRA_OEMAKE = 'STRIP=""'
Andrew Geissler90fd73c2021-03-05 15:25:55 -060043EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm --with-nobody-group=nogroup"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044
Brad Bishop316dfdd2018-06-25 12:45:53 -040045# rsync 3.0 uses configure.sh instead of configure, and
46# makefile checks the existence of configure.sh
47do_configure_prepend () {
48 rm -f ${S}/configure ${S}/configure.sh
49}
50
51do_configure_append () {
52 cp -f ${S}/configure ${S}/configure.sh
53}
54
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080055do_install_append() {
56 install -d ${D}${sysconfdir}
57 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
58}
59
Andrew Geissler6ce62a22020-11-30 19:58:47 -060060BBCLASSEXTEND = "native nativesdk"