blob: 375efa0dea512481b9ab8fbb25db2b22c3608610 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
4SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
Andrew Geissler475cb722020-07-10 16:00:51 -05006# Includes opennsh and xxhash dynamic link exception
Brad Bishop316dfdd2018-06-25 12:45:53 -04007LICENSE = "GPLv3+"
Andrew Geissler475cb722020-07-10 16:00:51 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
Brad Bishop316dfdd2018-06-25 12:45:53 -04009
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "popt"
11
12SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
13 file://rsyncd.conf \
14 file://makefile-no-rebuild.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050015 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geissler82c905d2020-04-13 13:39:40 -050019# -16548 required for v3.1.3pre1. Already in v3.1.3.
20CVE_CHECK_WHITELIST += " CVE-2017-16548 "
21
Andrew Geissler475cb722020-07-10 16:00:51 -050022inherit autotools-brokensep
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
Brad Bishop316dfdd2018-06-25 12:45:53 -040024PACKAGECONFIG ??= "acl attr \
25 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
26"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
Brad Bishop316dfdd2018-06-25 12:45:53 -040028PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
29PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler475cb722020-07-10 16:00:51 -050031PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
32PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
33PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
34PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
36# By default, if crosscompiling, rsync disables a number of
37# capabilities, hardlinking symlinks and special files (i.e. devices)
38CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040EXTRA_OEMAKE = 'STRIP=""'
Andrew Geissler475cb722020-07-10 16:00:51 -050041EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042
Brad Bishop316dfdd2018-06-25 12:45:53 -040043# rsync 3.0 uses configure.sh instead of configure, and
44# makefile checks the existence of configure.sh
45do_configure_prepend () {
46 rm -f ${S}/configure ${S}/configure.sh
47}
48
49do_configure_append () {
50 cp -f ${S}/configure ${S}/configure.sh
51}
52
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053do_install_append() {
54 install -d ${D}${sysconfdir}
55 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
56}
57
Brad Bishop316dfdd2018-06-25 12:45:53 -040058BBCLASSEXTEND = "native"