blob: 2425ef76a646d62c9711f9eebc76b1590ff782ba [file] [log] [blame]
Brad Bishop64c979e2019-11-04 13:55:29 -05001SUMMARY = "open source telephony"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
Brad Bishop64c979e2019-11-04 13:55:29 -05003HOMEPAGE = "http://www.ofono.org"
4BUGTRACKER = "https://01.org/jira/browse/OF"
5LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
7 file://src/ofono.h;beginline=1;endline=20;md5=3ce17d5978ef3445def265b98899c2ee"
Brad Bishop64c979e2019-11-04 13:55:29 -05008DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell"
9
10SRC_URI = "\
11 ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
12 file://ofono \
13 file://0001-mbim-add-an-optional-TEMP_FAILURE_RETRY-macro-copy.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050014 file://0002-mbim-Fix-build-with-ell-0.39-by-restoring-unlikely-m.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050015"
16SRC_URI[md5sum] = "1c26340e3c6ed132cc812595081bb3dc"
17SRC_URI[sha256sum] = "a15c5d28096c10eb30e47a68b6dc2e7c4a5a99d7f4cfedf0b69624f33d859e9b"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
Brad Bishop96ff1982019-08-19 13:50:42 -040019inherit autotools pkgconfig update-rc.d systemd gobject-introspection-data
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021INITSCRIPT_NAME = "ofono"
22INITSCRIPT_PARAMS = "defaults 22"
Brad Bishop64c979e2019-11-04 13:55:29 -050023SYSTEMD_SERVICE_${PN} = "ofono.service"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25PACKAGECONFIG ??= "\
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
Brad Bishop64c979e2019-11-04 13:55:29 -050028"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/,--with-systemdunitdir="
Brad Bishop96ff1982019-08-19 13:50:42 -040030PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
Brad Bishop15ae2502019-06-18 21:44:24 -040032EXTRA_OECONF += "--enable-test --enable-external-ell"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033
Andrew Geisslerc926e172021-05-07 16:11:35 -050034do_configure_prepend() {
35 bbnote "Removing bundled ell from ${S}/ell to prevent including it"
36 rm -rf ${S}/ell
37}
38
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039do_install_append() {
Andrew Geisslerc926e172021-05-07 16:11:35 -050040 install -d ${D}${sysconfdir}/init.d/
41 install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042}
43
44PACKAGES =+ "${PN}-tests"
45
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046FILES_${PN} += "${systemd_unitdir}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047FILES_${PN}-tests = "${libdir}/${BPN}/test"
Brad Bishop64c979e2019-11-04 13:55:29 -050048
49RDEPENDS_${PN} += "dbus"
50RDEPENDS_${PN}-tests = "\
51 python3-core \
52 python3-dbus \
53 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'python3-pygobject', '', d)} \
54"
55
56RRECOMMENDS_${PN} += "kernel-module-tun mobile-broadband-provider-info"