blob: 003c3accc384300136a9944e0568800e24b3c070 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "High level language (GLib) binding for D-Bus"
2DESCRIPTION = "GLib bindings for the D-Bus message bus that integrate \
3the D-Bus library with the GLib thread abstraction and main loop."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004HOMEPAGE = "https://www.freedesktop.org/Software/dbus"
Brad Bishop15ae2502019-06-18 21:44:24 -04005LICENSE = "AFL-2.1 | GPLv2+"
Andrew Geisslerc926e172021-05-07 16:11:35 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=c31c73c1d8f5d06784b2ccd22e42d641 \
7 file://dbus/dbus-glib.h;beginline=7;endline=21;md5=c374833bd817988323f3a8fda0dc7f48"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008SECTION = "base"
9
10DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
11DEPENDS_class-native = "glib-2.0-native dbus-native"
12
Andrew Geissler82c905d2020-04-13 13:39:40 -050013SRC_URI = "https://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014 file://no-examples.patch \
15 file://test-install-makefile.patch \
16"
Andrew Geisslerc926e172021-05-07 16:11:35 -050017SRC_URI[md5sum] = "021e6c8a288df02c227e4aafbf7e7527"
18SRC_URI[sha256sum] = "7d550dccdfcd286e33895501829ed971eeb65c614e73aadb4a08aeef719b143a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20inherit autotools pkgconfig gettext bash-completion gtk-doc
21
22#default disable regression tests, some unit test code in non testing code
23#PACKAGECONFIG_pn-${PN} = "tests" enable regression tests local.conf
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[tests] = "--enable-tests,,,"
26
27EXTRA_OECONF_class-target = "--with-dbus-binding-tool=${STAGING_BINDIR_NATIVE}/dbus-binding-tool"
28
29PACKAGES += "${PN}-tests"
30
31FILES_${PN} = "${libdir}/lib*${SOLIBS}"
32FILES_${PN}-bash-completion += "${libexecdir}/dbus-bash-completion-helper"
33FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
34FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
35
36RDEPENDS_${PN}-tests += "dbus-x11"
37FILES_${PN}-tests = "${datadir}/${BPN}/tests"
38
39BBCLASSEXTEND = "native"