blob: 109b40ce3df8e1125e8b0636cc663654e91e5b8d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003HOMEPAGE = "https://github.com/rpm-software-management/librepo"
4DESCRIPTION = "${SUMMARY}"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = "git://github.com/rpm-software-management/librepo.git \
9 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
10 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
11 "
12
Andrew Geisslerc926e172021-05-07 16:11:35 -050013SRCREV = "88b769eceefc1b151937e6b54d108b48f2177d87"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
18
19inherit cmake distutils3-base pkgconfig
20
21EXTRA_OECMAKE = " \
22 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
23 -DPYTHON_DESIRED=3 \
24 -DENABLE_TESTS=OFF \
25 -DENABLE_DOCS=OFF \
26 -DWITH_ZCHUNK=OFF \
27"
28
29BBCLASSEXTEND = "native nativesdk"