blob: 0a60ca74673defb7dff64b5e672511e8b0a0db70 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A sophisticated Numeric Processing Package for Python"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
Brad Bishop316dfdd2018-06-25 12:45:53 -04004SECTION = "devel/python"
Brad Bishop79641f22019-09-10 07:20:22 -04005LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
Andrew Geissler9b4d8b02021-02-19 12:26:16 -06006LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=aa1ecaef18152f75bfae546b29c49d3c"
Brad Bishop316dfdd2018-06-25 12:45:53 -04007
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14"
Andrew Geisslerc926e172021-05-07 16:11:35 -050015SRC_URI[sha256sum] = "c049f410c78e76ffb0af830a8afbdf8baac09897b4152b97b1a3b8345ee338ff"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020DEPENDS += "python3-cython-native"
21
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022inherit ptest setuptools3
23
Brad Bishop316dfdd2018-06-25 12:45:53 -040024S = "${WORKDIR}/numpy-${PV}"
25
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026CLEANBROKEN = "1"
27
Andrew Geissler475cb722020-07-10 16:00:51 -050028FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
Brad Bishop316dfdd2018-06-25 12:45:53 -040029
30# install what is needed for numpy.test()
31RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
32 ${PYTHON_PN}-difflib \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-pickle \
35 ${PYTHON_PN}-shell \
Brad Bishop316dfdd2018-06-25 12:45:53 -040036 ${PYTHON_PN}-doctest \
37 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-distutils \
39 ${PYTHON_PN}-misc \
40 ${PYTHON_PN}-mmap \
41 ${PYTHON_PN}-netclient \
42 ${PYTHON_PN}-numbers \
43 ${PYTHON_PN}-pydoc \
44 ${PYTHON_PN}-pkgutil \
45 ${PYTHON_PN}-email \
46 ${PYTHON_PN}-compression \
47 ${PYTHON_PN}-ctypes \
48 ${PYTHON_PN}-threading \
Brad Bishop79641f22019-09-10 07:20:22 -040049 ${PYTHON_PN}-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040050"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060051RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
52 ${PYTHON_PN}-hypothesis \
53 ${PYTHON_PN}-sortedcontainers \
54 ${PYTHON_PN}-resource \
55 ldd \
56"
Brad Bishop316dfdd2018-06-25 12:45:53 -040057
Brad Bishop316dfdd2018-06-25 12:45:53 -040058BBCLASSEXTEND = "native nativesdk"