blob: f5679a4ba22603277ea158f0fb4920033a694f42 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Python GObject bindings"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
3DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
Brad Bishopc342db32019-05-15 21:57:59 -04004SECTION = "devel/python"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
7
8GNOMEBASEBUILDCLASS = "meson"
9inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even
10
11DEPENDS += "python3 glib-2.0"
12
13SRCNAME="pygobject"
Brad Bishop96ff1982019-08-19 13:50:42 -040014
Brad Bishopc342db32019-05-15 21:57:59 -040015SRC_URI = " \
16 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
17 file://0001-Do-not-build-tests.patch \
18"
Andrew Geisslerc926e172021-05-07 16:11:35 -050019SRC_URI[sha256sum] = "00c6d591f4cb40c335ab1fd3e8c17869ba15cfda54416fe363290af766790035"
Brad Bishopc342db32019-05-15 21:57:59 -040020
21UNKNOWN_CONFIGURE_WHITELIST = "introspection"
22
Brad Bishopc342db32019-05-15 21:57:59 -040023S = "${WORKDIR}/${SRCNAME}-${PV}"
24
25PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
26
Brad Bishop08902b02019-08-20 09:16:51 -040027RDEPENDS_${PN} += "python3-pkgutil"
28
Brad Bishopc342db32019-05-15 21:57:59 -040029# python3-pycairo is checked on configuration -> DEPENDS
30# we don't link against python3-pycairo -> RDEPENDS
Andrew Geissler6ce62a22020-11-30 19:58:47 -060031PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
Brad Bishopc342db32019-05-15 21:57:59 -040032
Brad Bishopc342db32019-05-15 21:57:59 -040033BBCLASSEXTEND = "native"
34PACKAGECONFIG_class-native = ""