blob: fd4cf6d53845468ac7df8ec3f05d7876ec1b2b97 [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229"
10
Andrew Geisslerc926e172021-05-07 16:11:35 -050011SRCREV = "18eef33bd7a4bf5ad8c69f99cb72022608cf6e73"
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060012SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https \
13 file://0001-generate-glslang-pkg-config.patch"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060014UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
15S = "${WORKDIR}/git"
16
17inherit cmake python3native
18
19EXTRA_OECMAKE = " \
20 -DCMAKE_BUILD_TYPE=Release \
21 -DBUILD_SHARED_LIBS=ON \
22 -DENABLE_PCH=OFF \
23 -DENABLE_CTEST=OFF \
24 -DBUILD_EXTERNAL=OFF \
25"
26
27SOLIBSDEV = "glslang.so"
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060028# all the other libraries are unversioned, so pack it on PN
Andrew Geisslerd1e89492021-02-12 15:35:20 -060029FILES_${PN} += "${libdir}/*.so"
30
31BBCLASSEXTEND = "native nativesdk"