blob: abf0a67740bbf7da38fd49c3f87f4d75f3f1867c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Brad Bishop6dbb3162019-11-25 09:41:34 -050012 "
Andrew Geisslerc926e172021-05-07 16:11:35 -050013SRC_URI[sha256sum] = "0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8"
Brad Bishop19323692019-04-05 15:28:33 -040014
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
18inherit autotools multilib_header
19
20CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
21
22PACKAGECONFIG ?= "cxx jpeg zlib lzma \
23 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
24
25PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
26PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
27PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
28PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
29
30# Convert single-strip uncompressed images to multiple strips of specified
31# size (default: 8192) to reduce memory usage
32PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
33
34# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
35PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
36
37# Control picking up YCbCr subsample info. Disable to support files lacking
38# the tag
39PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
40
41# Support a mechanism allowing reading large strips (usually one strip files)
42# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
43PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
44
45PACKAGES =+ "tiffxx tiff-utils"
46FILES_tiffxx = "${libdir}/libtiffxx.so.*"
47FILES_tiff-utils = "${bindir}/*"
48
49do_install_append() {
50 oe_multilib_header tiffconf.h
51}
52
Andrew Geissler4ed12e12020-06-05 18:00:41 -050053BBCLASSEXTEND = "native nativesdk"