blob: cc6cc1e35c7b36a6b3875b5859af24bb87b17e7e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
Andrew Geisslerc9f78652020-09-18 14:11:35 -050018SRC_URI += " file://run-ptest"
19SRC_URI[archive.sha256sum] = "fe516b10711bbb6fd75011d66dd08fabfce18f7931aed7415136d53c4aadf1c5"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
24 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
25
26PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
27PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
28PACKAGECONFIG[thai] = ",,libthai"
29
30GTKDOC_MESON_OPTION = "gtk_doc"
31GIR_MESON_OPTION = 'introspection'
32
33do_configure_prepend_toolchain-clang() {
34 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
35}
36
37LEAD_SONAME = "libpango-1.0*"
38
39FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
40
41RDEPENDS_${PN}-ptest += "cantarell-fonts"
42RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
43
44RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
45 pango-module-basic-fc pango-module-arabic-lang"
46
47BBCLASSEXTEND = "native nativesdk"