blob: 6af7ab9cd8b87aec5c5e41b8f0c4498e3cb8940a [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001# Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
5HOMEPAGE = "https://github.com/pikhq/musl-nscd"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
8SECTION = "utils"
9
Andrew Geissler4b7c1152020-11-30 19:55:29 -060010DEPENDS += "flex-native bison-native flex bison"
11
Andrew Geisslera2681d92020-10-16 10:17:07 -050012PV = "1.0.2"
13
Andrew Geissler4b7c1152020-11-30 19:55:29 -060014SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
15SRC_URI = "git://github.com/pikhq/musl-nscd \
16 file://0001-Fix-build-under-GCC-fno-common.patch \
17 file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
Andrew Geissler32b11992021-03-31 13:37:05 -050018 file://0001-nsswitch.y-Replace-empty-bison-extension.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060019 "
Andrew Geisslera2681d92020-10-16 10:17:07 -050020
21UPSTREAM_CHECK_COMMITS = "1"
22
23inherit autotools-brokensep
24
25S = "${WORKDIR}/git"
26
27do_configure () {
28 # no debug set -s flag
29 sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
30 ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
31}
32
33do_compile () {
34 oe_runmake
35}
36
37do_install () {
38 make DESTDIR=${D} install
39}
40
41COMPATIBLE_HOST = ".*-musl.*"